summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1898074b5f4b..6495507541d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
pkgbase=python-class
-pkgname=("python-class" "python2-class")
-pkgver=2.7.2
+pkgname=("python-class")
+pkgver=2.9.3
pkgrel=1
pkgdesc="CLASS: Cosmic Linear Anisotropy Solving System"
arch=(any)
@@ -12,24 +12,15 @@ provides=()
conflicts=()
replaces=()
backup=()
+depends=('cython')
options=(!emptydirs)
install=
source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('06a0debf48fc6f06e6e8c0b82c36929d9475874f2773de57d7cea4d57f1467c3')
-package_python-class() {
- depends=('cython')
+sha256sums=('d20bbe92f320085a3f010fff20dbd3dd20968cb74fc5234f7a6b8de1c7164f90')
+package() {
cd "$srcdir/class_public-${pkgver}/"
make -j libclass.a
cd python
sed -i 's/libraries=\["class"\]/libraries=["class", "mvec", "m"]/' setup.py
python setup.py install --root="$pkgdir/" --optimize=1
}
-
-package_python2-class() {
- depends=('cython2')
- cd "$srcdir/class_public-${pkgver}/"
- make -j libclass.a
- cd python
- sed -i 's/libraries=\["class"\]/libraries=["class", "mvec", "m"]/' setup.py
- python2 setup.py install --root="$pkgdir/" --optimize=1
-}