summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 942f391f93bd..9e71ad8de02d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-clickgen
_name=${pkgname#python-}
-pkgver=1.2.0
+pkgver=2.1.1
pkgrel=1
pkgdesc="X11 & Windows cursor building API"
-arch=('x86_64')
+arch=('any')
url="https://github.com/ful1e5/clickgen"
license=('MIT')
-depends=('python-pillow' 'libx11' 'libxcursor' 'libpng')
+depends=('python-attrs' 'python-pillow' 'python-toml')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-provides=('xcursorgen.so')
-source=("$_name-$pkgver.tar.gz::https://github.com/ful1e5/clickgen/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('26d5fccced30a635e9a113bac2c71f7fcea95cb73cd904ae1405c16ef172b88f')
+#checkdepends=('python-pytest-cov')
+source=("$_name-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('43ca89b99989664654ec99fe72cb18a43f679b2b152720312156e26704864d83')
build() {
cd "$_name-$pkgver"
python -m build --wheel --no-isolation
-
- make -C src/xcursorgen
}
+#check() {
+# cd "$_name-$pkgver"
+# pytest --cov=clickgen --cov-report=html
+#}
+
package() {
cd "$_name-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
- local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- install -Dm644 src/xcursorgen/xcursorgen.so -t "${pkgdir}${site_packages}/$_name/"
-
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- ln -s "$site_packages/$_name-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}