summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ab3cf686520..942f391f93bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-clickgen
_name=${pkgname#python-}
-pkgver=1.1.9
+pkgver=1.2.0
pkgrel=1
pkgdesc="X11 & Windows cursor building API"
-arch=('any')
+arch=('x86_64')
url="https://github.com/ful1e5/clickgen"
license=('MIT')
depends=('python-pillow' 'libx11' 'libxcursor' 'libpng')
-makedepends=('python-setuptools')
-source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('2567bae2c08a45e4381954eb5bb76252519ed208ebe6f3d43cca83c11a854b9d')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+provides=('xcursorgen.so')
+source=("$_name-$pkgver.tar.gz::https://github.com/ful1e5/clickgen/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('26d5fccced30a635e9a113bac2c71f7fcea95cb73cd904ae1405c16ef172b88f')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
+
+ make -C src/xcursorgen
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -Dm644 src/xcursorgen/xcursorgen.so -t "${pkgdir}${site_packages}/$_name/"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "$site_packages/$_name-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}