summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae8fa7d94736
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Wouter de Vries <wouter@wbdv.nl>
+pkgname=python-clickhouse-cli-git
+_pkgname=clickhouse-cli
+pkgver=r107.9be5d7a
+pkgrel=1
+pkgdesc="Third-party client for the Clickhouse DBMS server"
+arch=(any)
+url="https://github.com/hatarist/clickhouse-cli"
+license=('MIT')
+depends=('python' 'python-sqlparse' 'python-pygments' 'python-prompt_toolkit' 'python-click')
+provides=('clickhouse-cli')
+options=(!emptydirs)
+source=('clickhouse-cli::git+https://github.com/hatarist/clickhouse-cli.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: