summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e71bf759c3ee..86742d6aaba1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=cobaya
-pkgname=python-$_modulename
+pkgname=python-cobaya
+_name=${pkgname#python-}
pkgver=3.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Code for Bayesian Analysis in Cosmology"
arch=(any)
-url="https://github.com/CobayaSampler/$_modulename"
+url="https://github.com/CobayaSampler/$_name"
license=()
groups=()
-depends=(python-numpy python-scipy python-pytz python-six python-dateutil python-pandas python-yaml wget python-pybobyqa python-kiwisolver python-pyparsing python-cycler python-matplotlib python-getdist python-fuzzywuzzy python-pyside2)
-makedepends=(python-setuptools)
+depends=(python-numpy python-scipy python-pytz python-six python-dateutil python-pandas python-yaml wget python-pybobyqa python-kiwisolver python-pyparsing python-cycler python-matplotlib python-getdist python-fuzzywuzzy pyside2)
+makedepends=(python-build python-installer)
provides=()
conflicts=()
replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('885b9ebb7f53556bd885102434274c2e15ad77d3ec30e5fc3b99078fcea06463')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('03b50d5a0bed89f5c2b014f610a2a7b052e1a65e639b578eca89a13975df09c3')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$_modulename-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}