summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90fbf82270c4..09ff1e7e9fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
# Maintainer: willemw <willemw12@gmail.com>
-_pkgname=python-code-chat
-pkgname=$_pkgname-git
-pkgver=1.9.0.r5.g05f02b3
+pkgname=python-code-chat-git
+pkgver=1.5.1.r242.g6809e75
pkgrel=1
-pkgdesc="Source code to HTML translator (literate programming)"
-arch=('any')
-url="https://github.com/bjones1/CodeChat"
-license=('GPL3')
-depends=('python-docutils')
-makedepends=('git' 'python-setuptools')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+pkgdesc='Source code to HTML translator (literate programming)'
+arch=(any)
+url=https://github.com/bjones1/CodeChat
+license=(GPL3)
+depends=(python-docutils)
+makedepends=(git python-build python-installer python-wheel python-setuptools)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
md5sums=('SKIP')
pkgver() {
+ git -C $pkgname describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ git -C $pkgname clean -dfx
+}
+
+build() {
cd $pkgname
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-