summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acbfc27275ac..46f3ff9adb26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Tong Chunli<t.cunly at 163 dot com>
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-output
-pkgver=0.2.3
+_name=${pkgname:7}
+pkgver=0.2.12
pkgrel=1
pkgdesc="An extension for colcon-core to customize the output in various ways."
arch=(any)
@@ -8,12 +10,12 @@ url="https://pypi.org/project/colcon-output/"
license=('Apache')
depends=('python-colcon-core')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/d2/3f/90578a9463d5af5160292f036f147bd316278577399958db77eb179cee78/colcon-output-$pkgver.tar.gz")
-sha256sums=('b0ce32be24ae33a50e70021c5965ef3b10df6aa4497d894f3ad5b230cf01ab56')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+sha256sums=('a211e9f1f70edb1567c0747532ad222e47799cef25cb863e4a43af4660798b30')
package() {
- cd ${srcdir}/colcon-output-${pkgver}
+ cd ${srcdir}/${_name}-${pkgver}
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"