summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14e2bd7efe31..ac432195421f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,10 @@ makedepends=('python-setuptools')
source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
sha256sums=('555c1b1653f9a97c1acb16fb350042b3cce5d692a13db9a6cbcc3b4de9b94beb')
-build() {
- cd ${srcdir}/${_name}-${pkgver}
- python -m build --wheel --no-isolation
-}
package() {
cd ${srcdir}/${_name}-${pkgver}
- python -m installer --destdir="$pkgdir" dist/*.whl
+
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}