summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6439615de2a6..39b90c174aa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,27 @@
pkgname=python-colored
_name=${pkgname#python-}
-pkgver=1.4.2
+pkgver=2.2.4
pkgrel=1
pkgdesc="Very simple Python library for color and formatting in terminal"
arch=('any')
url="https://gitlab.com/dslackw/colored"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('056fac09d9e39b34296e7618897ed1b8c274f98423770c2980d829fd670955ed')
+makedepends=(python-build python-flit python-installer python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "LICENSE")
+sha256sums=('595e1dd7f3b472ea5f12af21d2fec8a2ea2cf8f9d93e67180197330b26df9b61'
+ '6e38bc085fb26b5aa0db7b77be9893a805cce0badb2c2950d2fd36626b9a8dd1')
build() {
cd $_name-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
cd $_name-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}