summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ccbb81ee301..510c80060feb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Contributor: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
# Contributor: Julien Nicoulaud <julien.nicoulaud@gmail.com>
-pkgname=python-colorlog
-pkgver=2.7.0
+pkgname='python-colorlog'
+pkgver='2.7.0'
pkgrel=1
pkgdesc="Log formatting with colors"
-arch=(any)
-url="https://pypi.python.org/pypi/colorlog"
-license=(MIT)
-depends=(python)
-makedepends=(python-setuptools)
-conflicts=(python-colorlog-git)
-# Not using $pkgver here as we need to update the whole hashed URL anyways...
-source=("https://pypi.python.org/packages/95/59/c70e535f1b3b8eab2279dc58dc5ce1a780eb83efccefa55ca745dc7f02ee/colorlog-2.7.0.tar.gz")
+arch=('any')
+url='https://pypi.python.org/pypi/colorlog'
+license=('MIT')
+depends=('python')
+makedepends=('python-pip' 'python2-pip')
+conflicts=('python-colorlog-git')
+source=('https://pypi.python.org/packages/95/59/c70e535f1b3b8eab2279dc58dc5ce1a780eb83efccefa55ca745dc7f02ee/colorlog-2.7.0.tar.gz')
md5sums=('54709d93ee29bf61a2163e3019f4460e')
package() {
- cd "${srcdir}/colorlog-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "${srcdir}/colorlog-${pkgver}"
+ echo :: Installing for python2.7 ...
+ pip2 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+ echo :: Installing for python3.5 ...
+ pip3 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
}
-# vim: ft=sh et sts=2 ts=2 tw=79