summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73c525df1ad7..a9d739fe9856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+# Contributor: Antony Lee <anntzer dot lee at gmail dot com>
-_pyname=colorspacious
-pkgname=python-$_pyname
-pkgver=1.0.0
+pkgname=python-colorspacious
+pkgver=1.1.0
pkgrel=1
pkgdesc='A powerful, accurate, and easy-to-use Python library for doing colorspace conversions'
url='http://colorspacious.readthedocs.org/en/latest/'
depends=('python-numpy')
license=('MIT')
arch=('any')
-source=("https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.zip"
+source=("https://github.com/njsmith/colorspacious/archive/v$pkgver.tar.gz"
'LICENSE')
-md5sums=('437218f372a0a832a70299cc6397feb1'
+md5sums=('4eb0f86d6ecb5f5004d8ad61531eed45'
'032f6276b1a63e4062c163daae656d61')
build() {
- cd $srcdir/$_pyname-$pkgver
+ cd colorspacious-"$pkgver"
python setup.py build
}
package() {
- cd $srcdir/$_pyname-$pkgver
+ cd colorspacious-"$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}