summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a4350ac6592..58662abd4f31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Techcable <Techcable at techcable dot net>
pkgname=python-columnize
-pkgver=0.3.10
+pkgver=0.3.11
pkgrel=1
epoch=
pkgdesc="Python module to align a simple (not nested) list in columns."
@@ -15,24 +15,28 @@ backup=() # Anything we need to backup?
options=()
install=
changelog=
-source=("columnize-${pkgver}.tar.gz::https://github.com/rocky/pycolumnize/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=("c7947a57a126b6e5b4b585a19945909c3e64213979113948968304ebcf23daa4")
+# NOTE: Unfortunately 0.3.11 was released with an incorrect tag as 3.11
+#
+# TODO: Fix this once (or if) upstream fixes it
+wrong_pkgver=3.11
+source=("columnize-${pkgver}.tar.gz::https://github.com/rocky/pycolumnize/archive/refs/tags/${wrong_pkgver}.tar.gz")
+sha256sums=('dbcb3fc33f93da7d34542e7cd649f513cbe3cae7ad23f797c97499fc4ccba91e')
prepare() {
true; # Nothing to do I guess
}
build() {
- cd "pycolumnize-$pkgver"
+ cd "pycolumnize-$wrong_pkgver"
python3 ./setup.py build;
}
check() {
- cd "pycolumnize-$pkgver"
- make check;
+ cd "pycolumnize-$wrong_pkgver"
+ PYTHONPATH="." pytest test;
}
package() {
- cd "pycolumnize-$pkgver"
+ cd "pycolumnize-$wrong_pkgver"
python setup.py install --root="$pkgdir/" --prefix="/usr"
}