summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e137d926188
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname='python-consonance-git'
+pkgver=0.1.3.r0.gabe1a20
+pkgrel=1
+pkgdesc="implements WhatsApp's handshake process which makes use of Noise Pipes from Noise Protocol"
+url="https://github.com/tgalal/consonance"
+arch=('any')
+license=('GPL')
+depends=('python' 'python-transitions' 'python-protobuf' 'python-axolotl-curve25519' 'python-dissononce')
+makedepends=('python-setuptools')
+provides=('python-consonance')
+source=("${pkgname}::git+https://github.com/tgalal/consonance")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="$pkgdir/"
+}