summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfa4ffe95b5a..0b3d89e22e0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,6 @@
-# $Id$
-# Maintainer: Grey Christoforo <first name at last name dot net>
-
pkgname=python-cq_warehouse
-pkgver=0.7.0
-pkgrel=1
+pkgver=0.8.0
+pkgrel=2
pkgdesc="A cadquery parametric part collection"
arch=(x86_64)
url="https://github.com/gumyr/cq_warehouse"
@@ -13,11 +10,12 @@ python-cadquery
)
makedepends=(
python-build
+python-pytest
python-installer
)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gumyr/cq_warehouse/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('6c2783f7a948e7e2743d57b487568e733cd6f5b477565def31bed7bbb44b33b6')
+sha256sums=('150aca4cd339083a0f1184e6c56553ccc3d1a770992f100fd1c31e02ca56b427')
prepare() {
cd cq_warehouse-${pkgver}
@@ -30,10 +28,10 @@ build() {
python -m build --wheel --no-isolation
}
-check() {
- cd cq_warehouse-${pkgver}
- python -m unittest -v # project currently configured incorrectly for this to work
-}
+#check() {
+# cd cq_warehouse-${pkgver}/tests
+# python -m unittest -v # project currently configured incorrectly for this to work
+#}
package() {
cd cq_warehouse-${pkgver}