summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3653df6adb43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Bailey Fox <bfox200012@gmail.com>
+
+pkgname=('python-crccheck')
+_module=${pkgname#python-}
+pkgver='0.6'
+pkgrel=1
+pkgdesc="Calculation library for CRCs and checksums"
+url="https://bitbucket.org/martin_scharrer/crccheck"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.zip")
+sha256sums=('5686a4e5c3a2949597316c067c49c21e06051d13de9521434480cfa24dad7e32')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}