summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..263cf205036b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=crds
+pkgname=python-${_pyname}-doc
+pkgver=7.3.4
+pkgrel=1
+pkgdesc="Documentation for STScI CRDS"
+arch=('i686' 'x86_64')
+url="https://hst-crds.stsci.edu/static/users_guide/index.html"
+license=('BSD')
+makedepends=("python-${_pyname}=${pkgver}" 'python-sphinx-astropy' 'python-sphinx_rtd_theme' 'python-stsci_rtd_theme')
+source=("https://github.com/spacetelescope/${_pyname}/archive/${pkgver}.tar.gz")
+md5sums=('70a1f03bce0144b0e1c9c448420c8246')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/documentation/crds_users_guide
+
+ make html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/documentation/crds_users_guide/build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+}