summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af84df365b77..1bede16a196e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
pkgname=python-cupy
_pkgname=cupy
-pkgver=12.3.0
-_cub_commit=c3cceac115c072fb63df1836ff46d8c60d9eb304
-_jitify_commit=4a37de0be4639f222c6565ebd0654cb922b5180e
+pkgver=13.0.0
+_cccl_commit=3ef9dd9642da2d4e0b3ff77e445e73d7aabd4687
+_dlpack_commit=365b823cedb281cd0240ca601aba9b78771f91a3
+_jitify_commit=1a0ca0e837405506f3b8f7883bacb71c20d86d96
pkgrel=1
pkgdesc="NumPy-like API accelerated with CUDA"
url="https://cupy.dev"
@@ -14,18 +15,20 @@ depends=('cuda' 'python-fastrlock' 'python-numpy')
makedepends=('cudnn' 'cython0' 'nccl' 'python-setuptools')
optdepends=('cudnn' 'libcutensor' 'nccl')
source=("https://github.com/cupy/cupy/archive/v$pkgver.tar.gz"
- "https://github.com/NVIDIA/cub/archive/$_cub_commit.tar.gz"
+ "https://github.com/NVIDIA/cccl/archive/$_cccl_commit.tar.gz"
+ "https://github.com/dmlc/dlpack/archive/$_dlpack_commit.tar.gz"
"https://github.com/NVIDIA/jitify/archive/$_jitify_commit.tar.gz")
-md5sums=('9621d8be161bd1716e5db8e31ec953c0'
- 'ae6435aef98378a8b323b69f6665df33'
- '2ad752c0814c2da9909e2dcac0f50401')
+md5sums=('9ee621fba177cb2503988d4146522060'
+ '17c7f9635569aac243be498275ba71ba'
+ '4fbb2aeba1e0ef8d7e094deb811630df'
+ '0fb2589c81179e752d9bc45be72ed992')
prepare() {
cd "$srcdir/$_pkgname-$pkgver"
- rmdir third_party/cub
- ln -srfT "$srcdir/cub-$_cub_commit" third_party/cub
- rmdir cupy/_core/include/cupy/jitify
- ln -srfT "$srcdir/jitify-$_jitify_commit" cupy/_core/include/cupy/jitify
+ rm -rf third_party/{cccl,dlpack,jitify}
+ ln -srfT "$srcdir/cccl-$_cccl_commit" third_party/cccl
+ ln -srfT "$srcdir/dlpack-$_dlpack_commit" third_party/dlpack
+ ln -srfT "$srcdir/jitify-$_jitify_commit" third_party/jitify
}
build() {