summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38cf3df0b98d..b7abe212f94b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,17 @@
_pkgname=datalad
pkgname=python-$_pkgname
-pkgver=0.15.6
+pkgver=0.16.3
pkgrel=1
pkgdesc='Keep code, data, containers under control with git and git-annex'
arch=('any')
url='https://github.com/datalad/datalad'
license=('MIT')
depends=('python' 'git-annex'
- 'python-appdirs' 'python-chardet' 'python-distro' 'python-iso8601' 'python-humanize'
- 'python-fasteners' 'python-packaging' 'patool' 'python-tqdm' 'python-wrapt'
- 'python-annexremote'
+ 'python-platformdirs' 'python-chardet' 'python-distro' 'python-iso8601' 'python-humanize'
+ 'python-fasteners' 'python-packaging' 'patool' 'python-tqdm' 'python-annexremote'
'python-boto' 'python-keyring' 'python-keyrings-alt' 'python-msgpack' 'python-requests'
- 'python-pygithub' 'python-gitlab'
+ 'python-gitlab'
'python-simplejson' 'python-whoosh')
makedepends=('python-setuptools')
optdepends=('python-argcomplete: optional CLI completion'
@@ -26,7 +25,7 @@ optdepends=('python-argcomplete: optional CLI completion'
'python-xmp-toolkit: XMP metadata'
'python-pillow: generic image metadata')
source=("${_pkgname}-$pkgver.tar.gz::https://github.com/datalad/${_pkgname}/archive/$pkgver.tar.gz")
-sha512sums=('e1831fd6301033e71b5dc31f1b29f362847da47d1bfceeb19efba9594f42fe8e9c921b6074c8065c3ecb3193257569d2dbd59a55f1dfa5bcf4bfc3181eeff5c6')
+sha512sums=('31ddf80116de9474575ef216838737444b1a089788cf3c0699af2c40473b917900067dba69201838d01d7b2e830416a10557eab094ea3fac264794b619b6e804')
build() {
cd "$srcdir/${_pkgname}-$pkgver"