summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d7756bdc2e9..ee871919a16b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: AlphaJack <alphajack at tuta dot io>
pkgname="python-degiro-connector"
-pkgver=2.0.21
-pkgrel=2
+pkgver=2.0.22
+pkgrel=1
pkgdesc="Yet another library to access Degiro's API"
url="https://github.com/Chavithra/degiro-connector"
license=("BSD-3")
@@ -15,18 +15,17 @@ depends=("python"
"python-protobuf"
"python-requests"
"python-wrapt")
-# see https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=python-cleo-git
-makedepends=("python-pyproject2setuppy"
- "python-setuptools")
+makedepends=("python-build" "python-installer" "python-wheel")
source=("$pkgname-$pkgver.tar.gz::https://github.com/Chavithra/degiro-connector/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('b481986cd14b8b2ccff2eaeb2f47eb9706fbd76b863f98402afa1a7c26e7de99')
+sha256sums=('04015ecb3ddb1b23573abe02cbee2dc9fc42df58d65d3168fad436a7f82d795e')
+options=("!strip")
build(){
cd "degiro-connector-$pkgver"
- python -m pyproject2setuppy build
+ python -m build --wheel --no-isolation
}
package(){
cd "degiro-connector-$pkgver"
- python -m pyproject2setuppy install --skip-build --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}