summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6aef197e4d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname='python-dissononce-git'
+pkgver=0.34.3.r1.g4fad01e
+pkgrel=1
+pkgdesc="python implementation for Noise Protocol Framework"
+url="https://github.com/tgalal/dissononce"
+arch=('any')
+license=('MIT')
+depends=('python' 'python-cryptography' 'python-transitions')
+makedepends=('python-setuptools')
+provides=('python-dissononce')
+source=("${pkgname}::git+https://github.com/tgalal/dissononce")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="$pkgdir/"
+}