summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 22 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fcd835e1712..53d7af974d1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,42 @@
pkgname=python-distributed
_pkgname=distributed
-pkgver=2.5.2
+pkgver=2.6.0
pkgrel=1
pkgdesc="Python library for distributed computing"
arch=('any')
depends=('python>=3.5' 'python-click>=6.6' 'python-cloudpickle>=0.2.2'
-'python-dask>=2' 'python-msgpack' 'python-psutil>=5.0'
+'python-dask>=2.5.2' 'python-msgpack' 'python-psutil>=5.0'
'python-sortedcontainers>2.0.1' 'python-tblib' 'python-toolz>=0.7.4'
'python-tornado>=5' 'python-zict>=0.1.3' 'python-yaml')
optdepends=(
-# dev-requirements.txt
-'python-joblib>=0.10.2' 'python-pandas>=0.19.2' 'python-numpy>=1.11.0'
-'python-bokeh>=0.12.3' 'python-requests>=2.12.4' 'python-pyzmq>=16.0.2'
-'ipython>=5.0.0' 'python-jupyter_client>=4.4.0' 'python-ipykernel>=4.5.2'
-'python-pytest>=3.0.5' 'python-prometheus_client>=0.6.0'
-'python-jupyter-server-proxy>=1.1.0'
-# pytest.importorskip
-'python-keras' 'python-lz4' 'python-netcdf4' 'python-h5py'
-'python-paramiko' 'python-ipywidgets' # crick, hdfs-3
+ # Packages suggested in dev-requirements.txt
+ 'python-joblib: Joblib integration'
+ 'python-pandas: Pandas integration'
+ 'python-numpy: NumPy integration'
+ 'python-bokeh: Interactive visualisation of scheduler tasks'
+ 'python-pyzmq: Asynchronous messaging with ZeroMQ'
+ 'python-ipykernel: IPython integration for computing and debugging'
+ 'python-prometheus_client: Prometheus integration for monitoring and alerting'
+
+ # Packages which have optional unit tests (pytest.importorskip calls)
+ 'python-keras: Support for the Keras deep learning library'
+ 'python-lz4: LZ4 compression of messages'
+ 'python-netcdf4: Support for netCDF4 data files'
+ 'python-numba: JIT compilation of code'
+ 'python-h5py: Support for the HDF5 binary data format'
+ 'python-asyncssh: Computing cluster using SSH communication'
+ 'python-pytorch: Support for tensors and dynamic neural networks'
+ 'python-ipywidgets: Extra widgets in diagnostic pages'
)
url="http://distributed.readthedocs.org/en/stable/"
license=('BSD')
source=("$pkgver.tar.gz::https://codeload.github.com/dask/distributed/tar.gz/$pkgver")
-sha256sums=('4701f1ca503786a71dcf8a2cb29d91ca97c255f092c622b4e2d68b2e60ad1d8a')
+sha256sums=('2b3e602047cc72f44533b6ad7533943c57e908a5dbfa0dd37e116125948f98ff')
package() {
cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 || return 1
+ python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
install -d "$pkgdir/usr/share/licenses/$pkgname"
install LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname"
}