summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17e9800636f0..7e61974efbdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: getzze <getzze at gmail dot com>
-pkgname=('python-django-cacheops' 'python2-django-cacheops')
-pkgver=4.2
+pkgname='python-django-cacheops'
+pkgver=5.0.1
pkgrel=1
pkgdesc="A slick ORM cache with automatic granular event-driven invalidation"
arch=(any)
@@ -9,19 +9,12 @@ url="https://github.com/Suor/django-cacheops"
license=('custom')
options=(!emptydirs)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('271d20579dd95c7f58e5799cc8f2a8541f312f3fa263857ba22254a5863defc0')
-makedepends=('python-setuptools' 'python2-setuptools')
+sha256sums=('f6fc9453860cbafcd05d1ed8dee4674b298b97fa3b3f0096242b5f221d116971')
+depends=('python-django' 'python-redis')
+makedepends=('python-setuptools')
-package_python-django-cacheops() {
- depends=('python-django' 'python-redis')
+package() {
cd "$srcdir/django-cacheops-$pkgver"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --root="$pkgdir/" --optimize=1
}
-
-package_python2-django-cacheops() {
- depends=('python2-django' 'python2-redis')
- cd "$srcdir/django-cacheops-$pkgver"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python2 setup.py install --root="$pkgdir/" --optimize=1
-}