summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb1f89f60164..9eab3d4bf688 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,8 @@
# Maintainer: Jeremy Audet <jerebear@protonmail.com>
-#
-# namcap incorrectly states that python{,2}-{django,six} are unnecessary deps.
pkgbase=python-django-tables2
-_pkgbase="${pkgbase#python-}"
pkgname=(python-django-tables2 python2-django-tables2)
-pkgver=1.21.2
+pkgver=2.0.1
pkgrel=1
pkgdesc='A module for rendering Django data sets as HTML tables.'
arch=(any)
@@ -13,13 +10,13 @@ url='https://github.com/bradleyayers/django-tables2'
license=(MIT)
options=(!emptydirs)
makedepends=(python-setuptools python2-setuptools)
-source=("https://github.com/bradleyayers/${_pkgbase}/archive/v${pkgver}.tar.gz")
-sha256sums=('5c0c85cefb4e39f969030c8517e11180f239c64f7630a0e34ac8ef0d4ffc636a')
+source=("https://github.com/bradleyayers/django-tables2/archive/v${pkgver}.tar.gz")
+sha256sums=('faef491a9332c693316afb27d97191336fd673614a812ee6fdd32c47e581305e')
package_python-django-tables2() {
depends=('python-django>=1.11')
optdepends=('python-tablib: to export table data as CSV, XLS, etc.')
- cd "${srcdir}/${_pkgbase}-${pkgver}"
+ cd "${srcdir}/django-tables2-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
@@ -27,7 +24,7 @@ package_python-django-tables2() {
package_python2-django-tables2() {
depends=('python2-django>=1.11')
optdepends=('python2-tablib: to export table data as CSV, XLS, etc.')
- cd "${srcdir}/${_pkgbase}-${pkgver}"
+ cd "${srcdir}/django-tables2-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}