summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 315165962e27..c06a77a1a90f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Timothée Ravier <tim@siosm.fr>
pkgname=python-dulwich
-pkgver=0.12.0
+pkgver=0.16.1
pkgrel=1
pkgdesc='Pure-Python implementation of the Git file formats and protocols'
arch=('i686' 'x86_64')
url='https://www.dulwich.io/'
license=('GPL2')
depends=('python')
-source=("https://pypi.python.org/packages/source/d/dulwich/dulwich-${pkgver}.tar.gz")
+source=("https://www.dulwich.io/releases/dulwich-${pkgver}.tar.gz"{,.asc})
+validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij
+sha256sums=('470d0feec9d4e7aba091c02f62db7f9cc6549ffe3f623a8039f96f584159da05'
+ 'SKIP')
+sha384sums=('1f9efcb70aac84aeafaf1c6670af3510b86921f4d09f71b8b729a780e56e90dd17d319fdc002a7aad1ead0074c993882'
+ 'SKIP')
package() {
cd "dulwich-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
}
-
-sha256sums=('8f9070f37eec6175aab60d7064246b5b6453b2fab342589101f1c8feda0a0cc6')
-sha384sums=('8059b924d92d1001e911868ce7e272b0489c1e36be7da4e5278a77f0f17fe745524857e78fa2dd700b9dbf50b0ea213a')
-sha512sums=('55062a89d77294df849a8f59e0dd25c4d557fc3ea8e2de2c114c510ebe15ba876be54fad0889f1475855e3bf986f91e04b819dad3fe61f23b399553b59b26302')