summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e349d00e4f4..e1f87217931f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='python-e3-core'
pkgver='22.0.0'
-pkgrel=1
+pkgrel=2
pkgdesc="Framework to ease the development of portable automated build systems"
arch=('any')
@@ -10,18 +10,28 @@ url="https://github.com/AdaCore/e3-core"
license=('GPL3')
depends=('python-colorama'
- 'python-yaml'
+ 'python-distro'
'python-dateutil'
+ 'python-netifaces'
+ 'python-psutil'
'python-requests'
'python-requests-toolbelt'
+ 'python-stevedore>1.20.0'
'python-tqdm'
- 'python-stevedore>1.20.0')
+ 'python-yaml')
makedepends=('python-setuptools')
conflicts=('python2-e3-core')
_name='e3-core'
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha512sums=('1544c9cce9d7bab32db4617f70eaab301a526f84f8d89a22e5204eb7a7823a8e0103e12d490101a95d6255f3274732dbd77467064c856e1a05f8e7e18cce9f5a')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "distro.patch")
+sha512sums=('1544c9cce9d7bab32db4617f70eaab301a526f84f8d89a22e5204eb7a7823a8e0103e12d490101a95d6255f3274732dbd77467064c856e1a05f8e7e18cce9f5a'
+ '26ccd271cca25661ffc99154d44f210843f18e14641949d24d5a22bad0a62a449e5ed41eca1e5f8c409e504d20cccc9b5f9db3d2eadfc8214a02e26c6f99eee6')
+
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+ patch -Np0 -i "$srcdir/distro.patch"
+}
build() {
cd "$srcdir/$_name-$pkgver"