summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18fbe7f35640..0cc2a09bdd98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,36 @@
pkgname=python-easyocr-git
_name=EasyOCR
-pkgver=1.1.6.r297.a36bb9e
+_commit=19db7ba78903d79ffc7d789bd0427e8023525a02
+pkgver=1.6.2.r594.19db7ba
pkgrel=1
pkgdesc="Ready-to-use OCR with 40+ languages supported including Chinese, Japanese, Korean and Thai"
arch=("any")
url="https://github.com/JaidedAI/EasyOCR"
-license=("Apache")
+license=("Apache-2.0")
depends=(
'python-torchvision>=0.5' 'python-scikit-image'
- 'python-pytorch' 'opencv' 'hdf5'
+ 'python-pytorch' 'python-opencv' 'python-bidi'
+ 'python-pillow' 'python-numpy' 'python-yaml'
+ 'python-shapely' 'python-pyclipper' 'python-scipy'
)
-makedepends=('python-setuptools' 'git')
+makedepends=('python-setuptools' 'git' 'ninja')
#checkdepends=('python-pytest-runner')
optdepends=('python-torchvision-cuda>=0.5')
provides=('python-easyocr')
conflicts=('python-easyocr')
replaces=('python-easyocr')
-source=('git+https://github.com/JaidedAI/EasyOCR.git')
+source=("git+https://github.com/JaidedAI/EasyOCR.git#commit=${_commit}")
sha256sums=('SKIP')
install=${pkgname}.install
-prepare() {
- cd "$srcdir"/${_name} # -${pkgver}
- sed -i "s/opencv-python//g" requirements.txt
- #sed -i 's/Pillow<7.0/Pillow/g' setup.py
- cd easyocr
- sed -i '4d' detection.py
-}
+# prepare() {
+# cd "$srcdir"/${_name} # -${pkgver}
+# sed -i "s/opencv-python//g" requirements.txt
+# #sed -i 's/Pillow<7.0/Pillow/g' setup.py
+# cd easyocr
+# sed -i '4d' detection.py
+# }
build() {
cd "$srcdir"/${_name}