summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6d63f5ec54d..3cbbd410e2c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,25 @@
-# Maintainer: Michael Spradling <mike@mspradling.com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Michael Spradling <mike@mspradling.com>
+
+_name=EasyProcess
pkgname=python-easyprocess
-pkgver=0.2.3
+pkgver=0.2.9
pkgrel=1
-pkgdesc="EasyProcess is an easy to use python subprocess interface."
+pkgdesc="easy to use python subprocess interface"
arch=(any)
-url="https://pypi.python.org/pypi/EasyProcess"
+url="https://github.com/ponty/EasyProcess"
license=('BSD')
-depends=('python>=3.2' 'python-setuptools')
-source=(https://pypi.python.org/packages/0d/f1/d2de7591e7dfc164d286fa16f051e6c0cf3141825586c3b04ae7cda7ac0f/EasyProcess-${pkgver}.tar.gz)
-md5sums=('d08c91cbb2cc4603297968e1ed9eac0f')
+depends=('python' 'python-setuptools')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+md5sums=('a1008fc7b2cb69ff2f48a5fae201c24d')
+
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
package() {
- cd "${srcdir}/EasyProcess-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 || exit 1
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}