summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ad1c88c5800..1eb92eb71764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgbase=('python-ecos')
pkgname=('python-ecos')
_module='ecos-python'
-pkgver='2.0.4'
+pkgver='2.0.7'
+_pkgver="${pkgver}rc2"
pkgrel=1
pkgdesc="Python interface for ECOS."
url="https://github.com/embotech/ecos-python"
@@ -12,24 +12,31 @@ depends=('python'
'ecos'
'suitesparse')
makedepends=('python-setuptools')
+optdepends=('python-nose')
license=('GPL3')
-arch=('i686' 'x86_64')
-source=("https://github.com/embotech/ecos-python/archive/v${pkgver}.tar.gz"
+arch=('x86_64')
+source=("https://github.com/embotech/ecos-python/archive/${_pkgver}.tar.gz"
"use_external_ecos.patch")
-sha256sums=('d16907b0e9f41bbe7f43c37562e0d361db1f4d2e5fc7e91125899b4fdd062790'
- '49303c5fe700ccdc06fabdab87e5a0518b495fe32a99b2062f301e15dc4a0c72')
+sha256sums=('aba90a898da8a3f679e6169ee02c8d604960e721a6ff591671d2695efc5bab20'
+ 'c929cbe71cf8a109a66cbc681c6c501c42517b44e63f88440c36e5c7ca9e3be9')
prepare() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_module}-${_pkgver}"
patch -p1 < ../use_external_ecos.patch
}
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_module}-${_pkgver}"
python setup.py build
}
+check() {
+ cd "${srcdir}/${_module}-${_pkgver}"
+ python setup.py build_ext --inplace
+ nosetests
+}
+
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_module}-${_pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}