summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc5aa07da879..410196ac784c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-einsteinpy
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=0.3.1
+pkgver=0.4.0
pkgrel=1
pkgdesc="Python package for General Relativity"
arch=('i686' 'x86_64')
@@ -10,9 +10,8 @@ url="https://einsteinpy.org"
license=('MIT')
makedepends=('python-setuptools')
checkdepends=('python-pytest' 'python-matplotlib' 'python-astropy' 'python-scipy' 'python-sympy' 'python-plotly' 'python-numba')
-#'python-numba>0.49.0')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('208d50ec364eecc49a7d7db5de3bf83a')
+md5sums=('b6de4fa4af7f60b46b5f34b1457e8ed6')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -23,13 +22,12 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
-# python setup.py test
- PYTHONPATH="build/lib" pytest
+ python setup.py test
+# PYTHONPATH="build/lib" pytest tests
}
package_python-einsteinpy() {
depends=('python>=3.7' 'python-astropy' 'python-matplotlib' 'python-plotly>=4.0' 'python-scipy>=1.0' 'python-sympy>=1.1' 'python-numba' 'python-einsteinpy_geodesics')
- #'python-numba>0.49.0')
optdepends=('python-einsteinpy-doc: Documentation for EinsteinPy')
cd ${srcdir}/${_pyname}-${pkgver}