summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45844adae62b..bc5aa07da879 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
pkgbase=python-einsteinpy
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="Python package for General Relativity"
arch=('i686' 'x86_64')
-url="https://einsteinpy.org/"
+url="https://einsteinpy.org"
license=('MIT')
makedepends=('python-setuptools')
-checkdepends=('python-pytest' 'python-matplotlib' 'python-astropy' 'python-sympy' 'python-plotly' 'python-numba>0.49.0')
+checkdepends=('python-pytest' 'python-matplotlib' 'python-astropy' 'python-scipy' 'python-sympy' 'python-plotly' 'python-numba')
+#'python-numba>0.49.0')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('2e294b8c4ea8cbd248748cabec70bb9b')
+md5sums=('208d50ec364eecc49a7d7db5de3bf83a')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -27,7 +28,8 @@ check() {
}
package_python-einsteinpy() {
- depends=('python>=3.6' 'python-astropy' 'python-matplotlib' 'python-plotly>=4.0' 'python-sympy>=1.1' 'python-numba>0.49.0')
+ depends=('python>=3.7' 'python-astropy' 'python-matplotlib' 'python-plotly>=4.0' 'python-scipy>=1.0' 'python-sympy>=1.1' 'python-numba' 'python-einsteinpy_geodesics')
+ #'python-numba>0.49.0')
optdepends=('python-einsteinpy-doc: Documentation for EinsteinPy')
cd ${srcdir}/${_pyname}-${pkgver}