summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c460e2cf9ea4..2597ba17c2f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-einsteinpy-git
_gitname=einsteinpy
-pkgname=("python-${_gitname}-git")
-pkgver=0.1.0.r397.g17580ec
+pkgname=("python-${_gitname}-git" "python-${_gitname}-doc-git")
+pkgver=0.1.0.r400.g86b1e9c
pkgrel=1
pkgdesc="Python package for General Relativity"
arch=('i686' 'x86_64')
url="https://einsteinpy.org/"
license=('MIT')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-setuptools' 'python-nbsphinx' 'python-numba' 'pandoc' 'graphviz')
checkdepends=('python-pytest' 'python-matplotlib' 'python-sympy' 'python-plotly' 'python-astropy')
source=("git+https://github.com/einsteinpy/einsteinpy")
md5sums=('SKIP')
@@ -24,8 +24,10 @@ pkgver() {
build() {
cd ${srcdir}/${_gitname}
-
python setup.py build
+
+ msg "Building Docs"
+ PYTHONPATH="build/lib" python setup.py build_sphinx
}
check() {
@@ -46,3 +48,14 @@ package_python-einsteinpy-git() {
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
}
+
+package_python-einsteinpy-doc-git() {
+ pkgdesc="Documentation for EinsteinPy"
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+ cd ${srcdir}/${_gitname}/build/sphinx
+
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../COPYING
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+}