summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da25f6507254..ff03fc5cafd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,34 @@
# Contributor: Arthur Țițeică | arthur dot titeica with gmail
_pkgname=exchangelib
pkgname=python-exchangelib
-pkgver=4.7.2
+pkgver=4.7.6
pkgrel=1
pkgdesc="Client for Microsoft Exchange Web Services (EWS)"
arch=(any)
url="https://github.com/ecederstrand/exchangelib"
license=('BSD')
depends=('python-cached-property' 'python-cryptography' 'python-defusedxml' 'python-dnspython' 'python-isodate' 'python-lxml' 'python-requests-kerberos' 'python-requests-ntlm' 'python-requests-oauthlib' 'python-pytz' 'python-future' 'python-tzlocal')
-makedepends=('python-setuptools')
-checkdepends=('python-requests-mock')
+makedepends=(python-build python-installer python-wheel)
+checkdepends=(python-dateutil python-psutil python-requests-mock python-yaml)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ecederstrand/exchangelib/archive/refs/tags/v${pkgver}.tar.gz"
-"LICENSE")
-sha256sums=('12cc787f2e6c8cb15973c3ba4cc6a22bbbc0f0e8e7a9363146d90b1954e67313'
- '650d8ac6b0ab9a2c946b021bf12933cad611b6397d0eaff31beb28f6a243afa9')
+ "timezone.patch::https://github.com/ecederstrand/exchangelib/commit/d5d386f54adec8ab02f871332b89e1176c214ba2.patch")
+sha256sums=('ab8679e5236dd942b09dc8dcbe652d277246d3dfc726b63a8f212589b726c56a'
+ '38f92d4435a330e92e165edfea371c66fdc03c85c3e8a2914617a7faff1f9c3e')
+
+prepare() {
+ cd "${_pkgname}-$pkgver"
+ patch -p1 -i ../timezone.patch
+}
build() {
- cd "$srcdir/${_pkgname}-$pkgver"
- python setup.py build
+ cd "${_pkgname}-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${_pkgname}-$pkgver"
- python setup.py install -O1 --skip-build --root="${pkgdir}"
- install -Dm0644 ../../LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd "${_pkgname}-$pkgver"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
check() {