summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 55 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b003fac8bad..f1d72e0f3493 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,61 @@
-# Maintainer: sasvari <sasvari@fastmail.com>
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
pkgname=python-ezdxf
-_pkgname=ezdxf
-pkgver=0.8.7
+_commit=c64dd7133e2cd97abedddadd393898563c5dc67b
+pkgver=1.3.0
pkgrel=1
-pkgdesc="A Python package to create/manipulate DXF drawings."
-arch=(any)
-url="http://ezdxf.readthedocs.io/"
+pkgdesc="Python interface to DXF"
+arch=('x86_64')
+url=https://ezdxf.mozman.at/
license=('MIT')
-depends=('python')
-sha256sums=('882b2518fbdce86acb177c4f55d1f07034b385a96d6b22833962bad0f7983c57')
-source=("https://github.com/mozman/$_pkgname/archive/v$pkgver.tar.gz")
+depends=(
+python-typing_extensions
+python-pyparsing
+python-numpy
+python-fonttools
+)
+makedepends=(
+python-build
+python-installer
+python-wheel
+cython
+git
+)
+checkdepends=(
+python-nurbs
+python-pytest
+)
+source=("git+https://github.com/mozman/ezdxf.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ezdxf
+ git describe --tags | sed 's/^v//'
+}
+
+prepare() {
+ cd ezdxf
+}
+
+build() {
+ cd ezdxf
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd ezdxf
+ cd src
+ python -m pytest ../tests ../integration_tests -k 'not test_version and not test_audit_existing_file and not test_audit_file_not_found'
+}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --optimize=1 --root="$pkgdir/" --prefix="/usr"
+ cd ezdxf
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ # install examples
+ #mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ #cp -a examples "${pkgdir}/usr/share/${pkgname}"
+ #cp -a examples_dxf "${pkgdir}/usr/share/${pkgname}"
}
+
+# vim:ts=2:sw=2:et: