summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d07accb0da4f..89ccf34bf3bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
# Contributor: BigfootACA <bigfoot@classfun.cn>
pkgname=python-fastavro
-_name="${pkgname#python-}"
-pkgver=1.9.0
+_name=fastavro
+pkgver=1.9.1
pkgrel=1
pkgdesc="Fast read/write of AVRO files"
arch=('x86_64')
url="https://github.com/fastavro/fastavro"
license=('MIT')
-depends=('glibc' 'python-cramjam' 'python-lz4' 'python-snappy' 'python-zstandard')
+depends=('glibc' 'python' 'python-cramjam' 'python-lz4' 'python-snappy' 'python-zstandard')
makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('71aad82b17442dc41223f8351b9f28a60dd877a8e5a7525eaf6342f45f6d23e1')
+sha256sums=('f37011d66de8ba81b26760db0478009a14c08ebfd34269b3390abfd4616b308f')
-build(){
+build() {
cd "${_name}-${pkgver}"
python -m build --wheel --no-isolation
}
-package(){
+package() {
cd "${_name}-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"