summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c629b39989ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Davide Depau <davide@depau.eu>
+
+_pkgname='python-fastecdsa'
+pkgname="${_pkgname}-git"
+pkgver=2.1.2.r1.g4a16dae
+pkgrel=1
+pkgdesc='Python library for fast elliptic curve crypto'
+arch=('x86_64') # Please let me know if it works on other archs
+url='https://github.com/AntonKueltz/fastecdsa'
+license=('custom:Unlicense')
+depends=('python' 'gmp')
+makedepends=('python-setuptools')
+provides=("$_pkgname")
+source=("$_pkgname::git+https://github.com/AntonKueltz/fastecdsa.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+