summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 26 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35daaa7ef0c6..f21b87bbf758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,37 @@
-# Maintainer: peippo <christoph.fink@gmail.com>
+# Maintainer: peippo <christoph+aur@christophfink.com>
-pkgname='python-fasttext-git'
+pkgname=python-fasttext
pkgdesc="Library for fast text representation and classification – Python bindings"
url="https://github.com/facebookresearch/fastText"
-provides=('python-fasttext')
-conflicts=('python-fasttext')
+provides=("python-fasttext")
+conflicts=("python-fasttext")
-pkgver=0.2.0
-pkgrel=1
+pkgver=0.9.2
+pkgrel=5
-arch=('any')
-license=('BSD')
+arch=("x86_64")
+license=("BSD")
-makedepends=('python-setuptools' 'python2-setuptools')
-depends=('pybind11' 'python-future' 'python-numpy' 'python-scipy' 'python-pytorch')
+makedepends=("python-setuptools")
+depends=("pybind11" "python-future" "python-numpy" "python-scipy" "python-pytorch")
-source=("https://github.com/facebookresearch/fastText/archive/v${pkgver}.tar.gz")
-sha256sums=('71d24ffec9fcc4364554ecac2b3308d834178c903d16d090aa6be9ea6b8e480c')
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/facebookresearch/fastText/archive/v${pkgver}.tar.gz"
+ "${pkgname}-cstdint.patch"
+)
+b2sums=(
+ "ea3af92ce18d04241128cfb28773f0785a006e79c861d718c2c6ad788d776ad60b0543a42eb8be5a865cbc12283355521431fe2fba48544399e4a2b1520ff3f1"
+ "5d7c95b54ceb1998b4fd62ce11b6ac94f5c5f95f46488b8da79b04e2b7275bde6af105b120ef61ce81d16418a822b105cc84007f2398e6eb1982b916ff689281"
+)
+
+prepare() {
+ cd "${srcdir}/fastText-${pkgver}"
+ patch --forward --strip=1 --input "${srcdir}/${pkgname}-cstdint.patch"
+}
build() {
+ export CXXFLAGS="${CXXFLAGS} -std=c++0x"
cd "${srcdir}/fastText-${pkgver}"
python setup.py build
}
@@ -27,4 +39,6 @@ build() {
package() {
cd "${srcdir}/fastText-${pkgver}"
python setup.py install --root=${pkgdir} --optimize=1
+
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}