summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 573f69e085f4..77bdff8ebbd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,29 @@
pkgname=python-ffmpeg-progress-yield
_name=${pkgname#python-}
pkgver=0.7.8
-pkgrel=1
+pkgrel=4
pkgdesc="Run an ffmpeg command with its progress yielded."
arch=('any')
url="https://github.com/slhck/ffmpeg-progress-yield"
license=('MIT')
-depends=('python-colorama' 'python-setuptools' 'python-tqdm')
-optdepends=('ffmpeg: command line mode')
+depends=('ffmpeg' 'python-colorama' 'python-setuptools' 'python-tqdm')
+makedepends=('python-build' 'python-installer' 'python-wheel')
checkdepends=('ffmpeg' 'python-pytest')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v${pkgver}.tar.gz")
sha512sums=('0ffae9db1567e749b03face8d3b039b521e1273bc22128fa710fd94fc06bec30442b338d2dc2621d74354c81e7f79f77930e729b3178ece76e25c77fa9b6e637')
build() {
cd ${_name}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
+
check() {
cd ${_name}-${pkgver}
pytest test/test.py
}
+
package() {
cd ${_name}-${pkgver}
- python setup.py install --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}