summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 305c0a50dab9..920feb0f37de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
_name=fintech
pkgname=python-$_name
-pkgver=6.1.1
+pkgver=6.6.5
pkgrel=1
pkgdesc='Finance tech: SEPA, EBICS & more'
arch=(any)
-url="https://www.joonis.de/$_name"
+url="https://www.joonis.de/en/$_name/"
license=('custom:restricted use')
-depends=(python-certifi 'python-fpdf>=1.7.2' python-lxml)
-_pyarch=cp38
+_pyminor=9
+depends=("python>=3.$_pyminor" "python<3.$((_pyminor + 1))" python-certifi 'python-fpdf>=1.7.2' python-lxml)
+_pyarch=cp3$_pyminor
_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
sha256sums=('01cdf6e983b335601b53db04d6fd29a95c6906e88c89336fd20fc6985a1a1bdc')
noextract=("$_wheel")
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ local site="$pkgdir/usr/lib/python3.$_pyminor/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
}