summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8361c71a9d14..c1017ee5df52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=flake8-eradicate
pkgname=python-$_pkgname
-pkgver=1.2.0
+pkgver=1.4.0
pkgrel=1
pkgdesc="Flake8 plugin to find commented out or dead code"
@@ -11,17 +11,18 @@ url='https://github.com/sobolevn/flake8-eradicate'
arch=('any')
license=('MIT')
-depends=('python' 'python-setuptools' 'python-dephell' 'python-eradicate')
+depends=('python' 'python-setuptools' 'python-eradicate')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://github.com/sobolevn/$_pkgname/archive/$pkgver.zip")
-sha512sums=('0fca8d56724369b153ae9483e0a01ef664ae7a561428670b8f3adf0625bd44f5bf8418a41c548538844cbecb8908b3f83129d24b2f498823df046bbf9a7c46d2')
+sha512sums=('381039fbffb3cbf964e04fcd15744e0745ef3c2c03440e73ea1dee7af7fb04613a90babd167e0dd0d601a29ac11bbc63b3f4b3883ff80fba44de6b974dc60d08')
-prepare() {
+build() {
cd "$_pkgname-$pkgver"
- dephell deps convert --from pyproject.toml --to setup.py
+ python -m build --wheel --no-isolation
}
package() {
cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}