summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f33c85030ba0..c1017ee5df52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=flake8-eradicate
pkgname=python-$_pkgname
-pkgver=0.4.0
+pkgver=1.4.0
pkgrel=1
pkgdesc="Flake8 plugin to find commented out or dead code"
@@ -11,12 +11,18 @@ url='https://github.com/sobolevn/flake8-eradicate'
arch=('any')
license=('MIT')
-depends=('python' 'python-setuptools' 'python-dephell' 'python-eradicate')
+depends=('python' 'python-setuptools' 'python-eradicate')
+makedepends=('python-build' 'python-installer' 'python-wheel')
-source=("https://files.pythonhosted.org/packages/52/b5/ad7fce3e56fd4d9ff77ddcd4cebb8568a639bdbbbfa4b94eaae214d22d29/flake8-eradicate-0.4.0.tar.gz")
-sha512sums=('0e766dbe73b8d9879153517f69e882e9be7afaea6f6af87c8830496981203460ceeadeb2016f4785ba8af299433d5ce18125f853677c3a4d7403c3f655160f88')
+source=("https://github.com/sobolevn/$_pkgname/archive/$pkgver.zip")
+sha512sums=('381039fbffb3cbf964e04fcd15744e0745ef3c2c03440e73ea1dee7af7fb04613a90babd167e0dd0d601a29ac11bbc63b3f4b3883ff80fba44de6b974dc60d08')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}