summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a95896483f13..35fd5a8543fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=flake8-print
pkgname=python-$_pkgname
-pkgver=3.1.4
+pkgver=4.0.0
pkgrel=1
pkgdesc="Check for Print statements in python files."
@@ -11,13 +11,19 @@ url='https://github.com/jbkahn/flake8-print'
arch=('any')
license=('MIT')
-depends=('python')
+depends=(python)
+makedepends=(python-build python-installer python-wheel)
source=("https://github.com/JBKahn/$_pkgname/archive/$pkgver.tar.gz")
-sha512sums=('f5caf02478c1bd47df7f922b560de97be5dc103e61461dea5e84b20111761f259dd231fb8c53f45f921ac5b0b010daf0cd5cca6024eae8e33f434d301eaba6bb')
+sha512sums=('cb62bd5a68835c1b5439593259260da7f3ca0c28afe0306cae77d8527d7572b485ab09622b149d67a79671a7f20e9507d6f760a70fda3b48916032dd898f873e')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}