summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3de54c2e7250..52b474b6f465 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,17 @@
pkgname="python-flake8-simplify"
_pkgname="flake8-simplify"
-pkgver=0.18.0
+pkgver=0.19.2
pkgrel=1
pkgdesc="A flake8 plugin that helps you simplify your code."
arch=('any')
url="https://github.com/MartinThoma/flake8-simplify/"
license=('MIT')
depends=('flake8' 'python-astor')
-source=("https://github.com/MartinThoma/flake8-simplify/archive/$pkgver.tar.gz")
-md5sums=('06ebed3adc9ec3e2e087fde2e231ede7')
-
-build() {
- cd "${_pkgname}-${pkgver}"
- python setup.py build
-}
+makedepends=('python-installer')
+source=("https://files.pythonhosted.org/packages/py3/${_pkgname::1}/$_pkgname/${_pkgname//-/_}-$pkgver-py3-none-any.whl")
+md5sums=('ee1b98a55af98c1b4cf6158f14603338')
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" *.whl
}