summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 159a73b0a71f..8db0fdcc1bf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
-pkgname="flake8-sql"
+pkgname="python-flake8-sql"
+_pkgname=flake8-sql
pkgver=0.2.0
pkgrel=1
pkgdesc="Plugin that checks SQL code against opinionated style rules."
arch=('any')
-url="https://github.com/pgjones/${pkgname}"
+url="https://github.com/pgjones/${_pkgname}"
license=('MIT')
depends=('flake8')
+replaces=('flake8-sql')
+provides=('flake8-sql')
source=("https://github.com/pgjones/flake8-sql/archive/$pkgver.tar.gz")
md5sums=('1cde8e06c25aec0a415c32aafd8567f3')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"