summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea18e56319a9..8f1e8e152c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: neodarz <neodarz at neodarz dot net>
+# Maintainer: brodokk <brodokk at brodokk dot space>
_pkgname=flakehell
pkgname=python-$_pkgname
-pkgver=0.6.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="Flake8 wrapper to make it nice, legacy-friendly, configurable."
@@ -11,18 +11,19 @@ url='https://flakehell.readthedocs.io/'
arch=('any')
license=('MIT')
-depends=('python' 'python-setuptools' 'python-dephell' 'python-attrs' 'python-entrypoints' 'python-typing-extensions' 'python-termcolor' 'python-flake8-quotes' 'python-pygments' 'python-isort' 'python-pylint' 'python-urllib3' 'flake8' 'python-mccabe' 'python-flake8-commas')
+depends=('python' 'python-attrs' 'python-entrypoints' 'python-typing-extensions' 'python-termcolor' 'python-flake8-quotes' 'python-pygments' 'python-isort' 'python-pylint' 'python-urllib3' 'flake8' 'python-mccabe' 'python-flake8-commas')
+makedepends=(python-build python-installer)
-source=("https://github.com/life4/$_pkgname/archive/v.$pkgver.tar.gz")
-sha512sums=('5b2274b3ed6bd610db098dce3b6678dd886dfb7c308b688896c282c468ca16abee3b84afbe0998ec83be7291e0f481dc7d4c8d71b028595be4500f13bebdcad7')
+source=("https://github.com/flakehell/$_pkgname/archive/refs/tags/v.$pkgver.tar.gz")
+sha512sums=('8733d9cf5b19abf6170104837521e2950deeb5ea334e004ff920b4135a243bc51acbe95e907000f57220fbc7589bbaa43745fec27a6e0405dee08792f5dded79')
-prepare() {
+build() {
cd "$_pkgname-v.$pkgver"
- dephell deps convert --from pyproject.toml --to setup.py
+ python -m build --wheel --no-isolation
}
package() {
cd "$_pkgname-v.$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}