summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 085af8dff052..a725f917781a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pyname=fontParts
pkgname=python-${_pyname,,}
pkgver=0.9.11
-pkgrel=1
+pkgrel=2
pkgdesc='The replacement for RoboFab'
arch=(any)
url="https://github.com/robotools/${_pyname}"
@@ -13,7 +13,7 @@ _pydeps=(booleanoperations
defcon
fontmath
fontpens # for defcon[pens]
- 'fonttools>=4.26.1'
+ fonttools
fs # for fonttools[ufo]
lxml # for fonttools[lxml]
unicodedata2) # for fonttools[unicode]
@@ -26,7 +26,6 @@ sha256sums=('558a5f681fcf7ca0bb5a1c68917b5d9b61c77d517833a01ea1667773d13f4012')
build() {
cd "$_archive"
- export PYTHONHASHSEED=0
python setup.py build
}
@@ -37,6 +36,7 @@ check() {
package() {
cd "$_archive"
+ export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}