summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba147421d6fa..dd7614813b68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ pkgver='0.2.4'
pkgrel=1
pkgdesc='A collection of classes implementing the pen protocol for manipulating glyphs.'
url='https://pypi.org/project/fontPens/'
-checkdepends=('python-fontmath' 'python-fontparts' 'python-pytest' 'python>=3.8')
-depends=('python' 'python-fonttools')
+checkdepends=('python-fontmath' 'python-fontparts' 'python-pytest')
+depends=('python-fonttools')
makedepends=('python-setuptools')
optdepends=()
license=('BSD')
@@ -15,13 +15,13 @@ source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$p
sha256sums=('a6d9a14573b3450f3313d69523f9006028c21fc7aef5d35333b87aab7f2b41fd')
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}
-#check() {
- #cd "$srcdir/$_pkgname-$pkgver"
- #python setup.py test
-#}
+check() {
+ cd "$_pkgname-$pkgver"
+ pytest -k 'not fontPens.penTools.estimateQuadraticCurveLength' Lib/
+}