summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 769def7cb9d4..0fe6d1d65cf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=python-fonttools-git
-pkgver=4.26.1.r1.g032befd
+pkgver=4.50.0.r8.gac7e55b
pkgrel=1
pkgdesc='A library to manipulate font files from Python'
url='https://github.com/fonttools/fonttools'
@@ -10,7 +10,14 @@ arch=(x86_64)
depends=(python)
makedepends=(cython
git
- python-setuptools)
+ python-{build,installer}
+ python-setuptools
+ python-wheel)
+checkdepends=(python-brotli
+ python-fs
+ python-pytest
+ python-skia-pathops
+ python-ufolib2)
optdepends=('python-brotli: to compress/decompress WOFF 2.0 web fonts'
'python-fs: to read/write UFO source files'
'python-lxml: faster backend for XML files reading/writing'
@@ -20,6 +27,7 @@ optdepends=('python-brotli: to compress/decompress WOFF 2.0 web fonts'
'python-reportlab: to drawing glyphs as PNG images'
'python-scipy: for finding wrong contour/component order between different masters'
'python-sympy: for symbolic font statistics analysis'
+ 'python-uharfbuzz: to use the Harfbuzz Repacker for packing GSUB/GPOS tables'
'python-unicodedata2: for displaying the Unicode character names when dumping the cmap table with ttx'
'python-zopfli: faster backend fom WOFF 1.0 web fonts compression')
provides=("${pkgname%-git}=$pkgver")
@@ -35,13 +43,16 @@ pkgver() {
build() {
cd "$pkgname"
- export PYTHONHASHSEED=0
- python setup.py build_ext --inplace
- python setup.py build
+ python -m build -wn
+}
+
+check() {
+ cd "$pkgname"
+ PYTHONPATH=Lib pytest
}
package() {
cd "$pkgname"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
install -Dm0755 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}