summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..238e876aa682
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=python-fpdf2
+_name=${pkgname#python-}
+pkgver=2.3.0
+pkgrel=1
+pkgdesc='Simple PDF generation for Python'
+arch=(any)
+url='https://pyfpdf.github.io/fpdf2/'
+license=(LGPL3)
+conflicts=('python-fpdf')
+depends=('python-pillow')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a7583954ab7f9664c43ed1a3e523ee23f42649b366680f03b9a2397c795087ef')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}