summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a4338f9eefc..048c1ad1498a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=frida
pkgname=python-$_pkgname
-pkgver=16.0.5
+pkgver=16.0.6
pkgrel=1
pkgdesc="Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 3 version from PyPi"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -12,18 +12,20 @@ url="https://www.frida.re"
license=('custom:wxWindows Library License, Version 3.1')
depends=('python')
optdepends=('python-typing_extensions: for Python <3.8')
-source=("https://files.pythonhosted.org/packages/2d/29/afa117737f52755d604c5466fb0e8297c1dbf63f83c16d161b0910eb9f7a/${_pkgname}-${pkgver}.tar.gz"
+# Sourced from https://pypi.org/project/frida/#files
+source=("https://files.pythonhosted.org/packages/25/a8/eef7c1fe23e5fa4be243c8b360e091fdea63cbace5b66f4c266084f3e647/${_pkgname}-${pkgver}.tar.gz"
"COPYING")
+# Sourced from https://github.com/frida/frida/releases
source_i686=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-x86.tar.xz")
source_x86_64=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-x86_64.tar.xz")
source_armv7h=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-armhf.tar.xz")
source_aarch64=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-arm64.tar.xz")
-sha256sums=('95d9bf45b35a5aa8cad2a20f2f17a4d214e5d8b4518628ec31003f9d437f9412'
+sha256sums=('27dad72be7b68d3e165cdd219bd30db412762123355a51842a6d8307e010fdfe'
'5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2')
-sha256sums_i686=('ec1ca2e7e6d6b6b81becdbc65c57bbb3aeb0c4346fdac80aaa230230591e3d68')
-sha256sums_x86_64=('640874957b9d0c79d6366935c9f0d612f2d3b74083eaa8ef2ab96f541456a84c')
-sha256sums_armv7h=('eccc6c7e2a6bd7acc91107e4c6c6944c7843307bcabf7aad1891cb731eff5141')
-sha256sums_aarch64=('07f321353eaf6283f1854cdc3eccc6f5ea95d69ce750a761d23ca48178fbd4bc')
+sha256sums_i686=('a3a9874ff5f35bc98691eeac0dcf4b98c0c4dd096ea53019bb6a7a64283dab80')
+sha256sums_x86_64=('726b239c0e2de0177bd0af489438654edb1f8475a1a2fb7de9bf980763d3dd82')
+sha256sums_armv7h=('ec8d365c78332e5e96ffb8320b61c79b01d013c080f8cc69a868daa6ac14296f')
+sha256sums_aarch64=('7f47bf7241da16385356bbfd13d8f86e45c471573df6ef24b0c6bf630f0b9182')
noextract=("frida-core-devkit-${pkgver}-linux.tar.xz")
conflicts=("python2-${_pkgname}")