summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc6fe4d7c9c3..abc93b10c6ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=1.0.0
pkgrel=1
pkgdesc='More higher-order functions and operations on callable objects.'
arch=('any')
-url="https://github.com/coNQP/${_pkgbase}"
+url="https://github.com/homeinfogmbh/${_pkgbase}"
license=('GPLv3')
depends=('python')
makedepends=('git' 'python' 'python-pytest' 'python-setuptools' 'python-setuptools-scm')
@@ -14,6 +14,12 @@ source=("${_pkgbase}::git+${url}.git#tag=${pkgver}")
md5sums=('SKIP')
+check() {
+ cd "${srcdir}/${_pkgbase}"
+ pytest
+}
+
+
package() {
cd "${srcdir}/${_pkgbase}"
python setup.py install --root "${pkgdir}" --optimize=1